testing status page
Incident Report for ProctorExam
Resolved
This incident has been resolved.
Posted Sep 06, 2023 - 14:14 UTC
Identified
This a test please disregard.
Posted Sep 06, 2023 - 14:12 UTC
This incident affected: Contacting Support Team.