Our support.proctorexam.com is currently unavailable for some users to contact support
Incident Report for ProctorExam
Resolved
This incident has been resolved, and our support.proctorexam.com is now accessible again.
Posted Jan 31, 2023 - 10:34 UTC
Investigating
Our support.proctorexam.com is currently unavailable for some users to contact support. If you have an immediate support requests and are unable to reach our Help Center please email us directly at proctorexam-support@turnitin.com.
Posted Jan 31, 2023 - 10:13 UTC
This incident affected: Contacting Support Team.