ProctorExam chrome extension not available for download on the chrome library.
Incident Report for ProctorExam
Postmortem

On 27 May, 12:30 UTC, we started receiving complaints that the Proctorexam Screensharing Chrome extension was not available for download anymore from the Google Chrome Webstore.

We quickly found out that the extension had indeed the status “Taken down”. No communication has been received from Google as to why this happened. All emails have been checked, spam folders and a thorough check from our IT department in our email servers to find any email that might have slipped through.

We immediately proceeded to re-publish the same extension at 27 May, 15:30 UTC.

On 28 May, the extension was rejected because it was requesting permission to access an API that isn’t used. We removed the request for accessing the specific API from the extension’s manifest and re-submitted the extension on 28 May at 13:00 UTC.

The new extension v1.6.0 was approved in the morning of 30 May. We never received an email from Google about this approval.

We suspect that new Google Chrome Webstore rules were put in place earlier and enforced with a deadline, causing our extension to be taken down for violation of these new rules. However we never received any communication from Google about it and also haven’t yet received any reply on our support requests.

Posted Jun 02, 2022 - 10:26 UTC

Resolved
This issue has been resolved. The Chrome plugin is working again, and you can use ProctorExam as normally.
Posted May 30, 2022 - 07:40 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 30, 2022 - 07:35 UTC
Identified
The issue has been identified and a fix is being implemented.

In the meantime, the chrome extension can be downloaded from our repository. In order to do this, candidates can follow this protocol:
1. Download the Extension here
https://docs.proctorexam.com/chrome-extension/extension_1_5_5_0.crx
(you may disregard the notification, this is from Proctor Exam and it is safe to download)
2. After downloading, kindly open a chrome tab, and paste this link:
chrome://extensions/
3. On the top right, activate the Developer Mode
4. Drag and Drop the downloaded file to extension page

Kindly share this information with the candidates in order for them to have the extension on when they get to their test.

Our support agents will guide candidates who have trouble with this.
Posted May 27, 2022 - 14:11 UTC
This incident affected: European Cluster EU2 (EU2 - Taking Exams), US Cluster US1 (US1 - Taking Exams), Canadian Cluster CA1 (CA1 - Taking Exams), and European Cluster EU3 (EU3 - Taking Exams).